Merge request diffs for comments unavailable for parts of December / JanuaryOperational

Components

Website

Locations

Google Compute Engine



January 20, 2025 12:09 UTC
[Resolved] After a monitoring period, we confirmed that the issue is now resolved and the diffs are showing again as expected. Please reach out to our Support team if you encounter issues.

January 20, 2025 03:02 UTC
[Monitoring] No material updates to report. Our team continue to monitor the fix. Another update will be provided in 24 hours.

January 19, 2025 01:09 UTC
[Monitoring] No material updates to report. We're continuing to assess the scope of impact and monitoring the fix. Another update will be provided in 24 hours.

January 18, 2025 02:34 UTC
[Monitoring] No material updates to report. We are still monitoring the fix and we will provide an update in 24 hours.

January 17, 2025 09:26 UTC
[Monitoring] The deploy to production has finished and image diff comments are rendered correctly again. Our engineers are monitoring the situation. The next update can be expected in 12 hours.

January 16, 2025 17:15 UTC
[Identified] The fix for Merge Request diff comments has been deployed to production. We are still working on a fix for image diff comments. MR: gitlab.com/gitlab-org/gitlab/-/merge_requests/178143. We will update once this has been deployed to production.

January 16, 2025 08:29 UTC
[Identified] A fix has been merged and is getting deployed to production. We will update the status page again, once the fix has been deployed successfully.

January 16, 2025 00:08 UTC
[Identified] We have been analyzing impacted merge request diff comments; we have noticed that some diff notes do not have a Reply form. We are working on a fix in this Merge Request: gitlab.com/gitlab-org/gitlab/-/merge_requests/178057

January 15, 2025 16:54 UTC
[Identified] We have verified the fix in production and it has been rolled out to all GitLab.com projects. The majority of comment display issues have been fixed and we are working on a followup to resolve any remaining issues.

January 15, 2025 08:07 UTC
[Identified] A fix for impacted diff comments has been merged, and is getting deployed to production. In our next status update, we will notify when the fix is in production.

January 15, 2025 00:27 UTC
[Identified] The issue where diff comments are sometimes not showing in Merge Requests appears to be a display issue. A initial fix was deployed on Jan 8 to prevent further occurrences. A fix for impacted diff comments is in progress.

January 14, 2025 20:29 UTC
[Identified] We are aware of an issue where diffs are not showing in some cases on merge requests created between December 9 and Jan 8. We are continuing to research and will update when we have further updates.

January 14, 2025 16:24 UTC
[Identified] We're aware of an issue where merge request comments created between Dec 9th and Jan 8th may contain comments that are no longer associated with a diff.

Back to current status