Intermittent timeouts for requests from some Utah IP addressesOperational

Components

Git Operations, Container Registry

Locations

Google Compute Engine



December 20, 2024 02:51 UTC
[Resolved] We are now marking this incident as resolved. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/19017

December 19, 2024 01:48 UTC
[Monitoring] Google's network engineers have identified the issue affecting the "us-west3" region and deployed a fix. We will continue monitoring. For questions and more details, please follow gitlab.com/gitlab-com/gl-infra/production/-/issues/19017.

December 18, 2024 22:15 UTC
[Investigating] No material updates at this time. Cloudlfare and Google are still investigating these routing issues. We will provide additional information as it becomes available. Details will be posted to: gitlab.com/gitlab-com/gl-infra/production/-/issues/19017

December 18, 2024 03:57 UTC
[Investigating] Our Infrastructure Engineers have been working with CloudFlare and Google and have identified a routing issue between GCP "us-west3" and Cloudflare. Investigation is continuing. Please follow gitlab.com/gitlab-com/gl-infra/production/-/issues/19017 for more details.

December 17, 2024 22:37 UTC
[Investigating] No material updates at this time. Requests originating from the Salt Lake City, Utah region may still see intermittent timeouts. We are working with our third party vendor to investigate further. We will provide updates as info becomes available. Details: gitlab.com/gitlab-com/gl-infra/production/-/issues/19017

December 17, 2024 13:45 UTC
[Investigating] No material updates at the moment. We continue to work with a third party vendor to get more updates and waiting for feedback from affected customers. Details to follow in: gitlab.com/gitlab-com/gl-infra/production/-/issues/19017

December 16, 2024 23:49 UTC
[Investigating] We have received some reports of requests timing out for IP addresses originating in Salt Lake City, Utah. We are working with a third party vendor to identify the issue. Details to follow in: gitlab.com/gitlab-com/gl-infra/production/-/issues/19017

Back to current status