Runner registration returning 500 errorsOperational

Components

CI/CD - Hosted runners on Linux, CI/CD - Hosted runners on Windows, CI/CD - Hosted runners on macOS, CI/CD - Hosted runners for GitLab community contributions

Locations

Google Compute Engine



December 11, 2024 13:34 UTC
[Resolved] This incident has been resolved and runner registration is now fully operational. More information can be found in gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

December 11, 2024 11:47 UTC
[Monitoring] The fix has been deployed to production and we are no longer seeing these errors. We will continue monitoring. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

December 11, 2024 11:06 UTC
[Identified] The deployment to production has started and we are expecting it to complete in approximately 1 hour. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

December 11, 2024 04:56 UTC
[Identified] A fix for this problem has been merged into the codebase - it should become available on GitLab.com in the next 6-7 hours. For more information please see gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

December 11, 2024 04:36 UTC
[Identified] As a workaround is available (using an authentication token to register a new runner) the status of this incident has been downgraded to 'Partial Service Disruption'

December 11, 2024 04:10 UTC
[Identified] Work to fix the deprecated runner registration method continues. Workaround: register runner with an authentication token. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

December 11, 2024 03:39 UTC
[Identified] Work continues to fix the deprecated runner registration method. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/18984 Workaround: register runner with an authentication token.

December 11, 2024 02:59 UTC
[Identified] A workaround has been identified to register a runner using an authentication token: docs.gitlab.com/runner/register/#register-with-a-runner-authentication-token Incident only impacting the deprecated runner registration method.

December 11, 2024 02:50 UTC
[Identified] Work continues for a fix to the identified cause. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

December 11, 2024 02:22 UTC
[Identified] We are seeing 500 errors with runner registrations. We have identified the cause, and are working on a fix. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/18984

Back to current status