Runner authentication verification API errorsOperational

Components

API

Locations

Google Compute Engine



October 31, 2024 22:50 UTC
[Resolved] After a period of monitoring we confirmed that the issue has been resolved.

October 31, 2024 22:39 UTC
[Monitoring] We've manually applied a fix that has stopped the error rate and mitigated the incident. We'll be monitoring for a time to ensure the issue doesn't recur. Details: gitlab.com/gitlab-com/gl-infra/production/-/issues/18792.

October 31, 2024 18:51 UTC
[Identified] We're finalizing the next method we'll be using to mitigate the incident and will be attempting another fix shortly. Details in gitlab.com/gitlab-com/gl-infra/production/-/issues/18792.

October 31, 2024 17:42 UTC
[Identified] Deployment of the fix has completed, but it is not having the impact we hoped for. We're currently weighing options for a second fix. Details in gitlab.com/gitlab-com/gl-infra/production/-/issues/18792.

October 31, 2024 14:50 UTC
[Identified] We have identified and pushed the fix, and it is currently in the process of being deployed. For more details, see the production issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/18792

October 31, 2024 09:19 UTC
[Identified] We have identified the cause of the errors, and are currently working on the fix. For more details, see the incident issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/18792

October 31, 2024 08:42 UTC
[Investigating] We are seeing elevated error rates on the POST /runners/verify endpoint. We are currently investigating. See the infrastructure issue for details: gitlab.com/gitlab-com/gl-infra/production/-/issues/18792

Back to current status