Pipelines using SaaS Runners stuck on Pending statusOperational

Components

CI/CD - Hosted runners on Linux

Locations

Google Compute Engine



October 9, 2024 08:38 UTC
[Resolved] Pipeline jobs are now being picked up by Runners based on our monitoring. We are marking this incident as resolved. See gitlab.com/gitlab-com/gl-infra/production/-/issues/18679

October 8, 2024 23:31 UTC
[Monitoring] We've discovered this incident also impacted self-managed Runners when attempting to verify their credentials on GitLab.com. 404 errors were generated, preventing job execution. See gitlab.com/gitlab-com/gl-infra/production/-/issues/18679.

October 8, 2024 22:39 UTC
[Monitoring] Next update for this incident will be once the revert MR is deployed to production. Please follow gitlab.com/gitlab-com/gl-infra/production/-/issues/18679 for more details.

October 8, 2024 22:38 UTC
[Monitoring] Pipelines processed by GitLab-hosted runners are back to normal operation after the rollback. A revert MR is in process to be deployed to production which will address the root cause of the issue. See gitlab.com/gitlab-com/gl-infra/production/-/issues/18679.

October 8, 2024 22:02 UTC
[Monitoring] We have performed a deployment rollback and previously stuck pipelines are being picked up. We will start a monitoring window for 30 minutes to confirm incident resolution. See gitlab.com/gitlab-com/gl-infra/production/-/issues/18679.

October 8, 2024 21:44 UTC
[Identified] We are receiving reports of CI Pipelines failing to start and stuck on Pending status. This is only affecting pipelines using GitLab-hosted runners. A fix has already been identified and should be deployed to production soon. Please see gitlab.com/gitlab-com/gl-infra/production/-/issues/18679.

Back to current status