October 4, 2024 06:59 UTC
October 3, 2024 22:23 UTC
[Monitoring] The fix has been successfully merged, but we are still waiting for the changes to reach production. We will continue to monitor Sidekiq’s performance, and the next update will be provided once the incident has been mitigated. For more details, visit gitlab.com/gitlab-com/gl-infra/production/-/issues/18660 October 3, 2024 21:04 UTC
October 3, 2024 20:00 UTC
[Monitoring] The fix is expected to be merged soon. In the meantime, we’ll continue monitoring Sidekiq’s performance. Updates to MR approval policies will remain delayed until the issue is fully resolved. For more details, visit gitlab.com/gitlab-com/gl-infra/production/-/issues/18660 October 3, 2024 19:02 UTC
[Monitoring] We are still awaiting the deployment of the fix and will continue to monitor Sidekiq’s performance in the meantime. Updates to MR approval policies are delayed until the issue is resolved. For more details, visit gitlab.com/gitlab-com/gl-infra/production/-/issues/18660 October 3, 2024 18:02 UTC
October 3, 2024 17:06 UTC
October 3, 2024 15:55 UTC
[Monitoring] We're continuing to monitor the performance of Sidekiq until the fix is deployed. Updates to MR approval policies are still processed with delays. The MR to fix the root cause is currently waiting to be merged.
More details about this incident can be found in gitlab.com/gitlab-com/gl-infra/production/-/issues/18660 October 3, 2024 14:46 UTC
October 3, 2024 14:28 UTC
[Monitoring] We've identified the root cause and are recovering from a high volume of request traffic and are seeing improvements. Updates to MR approval policies are currently processing but with delays.
More details about this incident can be found in gitlab.com/gitlab-com/gl-infra/production/-/issues/18660 October 3, 2024 14:12 UTC