September 4, 2024 20:07 UTC
September 4, 2024 19:46 UTC
[Monitoring] A fix has been implemented and we are monitoring the results.
September 4, 2024 19:04 UTC
[Investigating] The Customers Portal (customers.gitlab.com) is in maintenance mode due to a 3rd-party API being down. The billing pages in GitLab.com may be affected.