Pipeline jobs not being picked up and 500 errorsOperational

Components

Website, API, CI/CD - Hosted runners on Linux, Background Processing

Locations

Google Compute Engine



May 17, 2024 02:14 UTC
[Resolved] Ongoing monitoring is showing that all systems are working without issue. Google has also resolved their incident. We will mark this incident as resolved. See following issue for more information: gitlab.com/gitlab-com/gl-infra/production/-/issues/18023

May 17, 2024 00:48 UTC
[Monitoring] We are seeing normal functionality again in our logging but we will continue monitoring. If you are still seeing these issues, please comment in the production issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/18023

May 17, 2024 00:24 UTC
[Identified] We have identified that these outages are impacted by the Google Cloud Service disruptions. For more information, see gitlab.com/gitlab-com/gl-infra/production/-/issues/18023. To follow Google Cloud status information, see status.cloud.google.com/incidents/xVSEV3kVaJBmS7SZbnre#RP1d9aZLNFZEJmTBk8e1

May 17, 2024 00:01 UTC
[Investigating] GitLab is investigating reports of pipelines not being picked up and 500 errors. We have two incidents open and we are working to understand the cause of these errors and whether they are related. We are investigating if this is related to this Google issue: status.cloud.google.com/incidents/xVSEV3kVaJBmS7SZbnre#RP1d9aZLNFZEJmTBk8e1 Issue links: gitlab.com/gitlab-com/gl-infra/production/-/issues/18024, gitlab.com/gitlab-com/gl-infra/production/-/issues/18023

Back to current status