Stuck merge requestsOperational

Components

Website

Locations

Google Compute Engine



April 29, 2024 15:06 UTC
[Resolved] We are closing this incident because the system is operational. There are still 1489 merge requests in an incorrect state. We are working on correcting them and discussing options in the issue. More details are available in gitlab.com/gitlab-com/gl-infra/production/-/issues/17921.

April 29, 2024 11:29 UTC
[Identified] We are working on unlocking the affected merge requests. A workaround for the "Merge request is not mergeable" error is to close and reopen the merge request.

April 29, 2024 11:04 UTC
[Investigating] We had an increased rate in web service errors. The errors cleared, but some merge requests remained in a locked state. We are working on unlocking these merge requests, more details are available in gitlab.com/gitlab-com/gl-infra/production/-/issues/17921.

Back to current status