Email delivery delaysOperational

Components

Background Processing

Locations

Google Compute Engine



January 25, 2024 17:45 UTC
[Resolved] No further email delays have been reported by our users while our new IP's continue to warm up for the next couple of days. We consider this incident resolved until new reports are received. See gitlab.com/gitlab-com/gl-infra/production/-/issues/17404 for details.

January 19, 2024 23:34 UTC
[Monitoring] Earlier this week, we added additional IPs to our mail server. As these IPs go through the warm-up phase, we anticipate ongoing improvements. Expect additional updates on Monday, unless notable changes necessitate earlier communication. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 19, 2024 04:28 UTC
[Monitoring] We continue to monitor email delivery for improvements after mitigation steps have been implemented. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 19, 2024 04:24 UTC
[Monitoring] We continue to monitor email delivery for improvements after mitigation steps have been implemented. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 18, 2024 18:15 UTC
[Monitoring] Although there are signs of improvement in email delivery delays, reports of delayed emails from certain users persist. We aim to identify additional options for further mitigation and continue to monitor the situation closely. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 18, 2024 00:30 UTC
[Monitoring] Indications are that the email delivery delay has improved, however we are still receiving reports of late arriving email by some users. We are continuing our analysis to determine options to further mitigate the delayed delivery.

January 17, 2024 00:31 UTC
[Monitoring] Further monitoring indicates an improvement since the changes were implemented. We will continue to monitor and provide an update once we have concluded a measurable success. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 23:31 UTC
[Identified] We have initiated a change aimed at resolving the email delays. The full implementation of this change may take 24-48 hours to show results. We will continue to monitor the situation and provide the next update once we confirm the effectiveness of the changes. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 22:02 UTC
[Identified] We're working on implementing mitigation measures to address the email delays. Our team is monitoring the situation, and we will provide an update as soon as additional information becomes available. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 19:55 UTC
[Identified] Our team continues to work on resolving this issue as swiftly as possible. We will post the next update when we have significant developments to share. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 18:44 UTC
[Identified] We are actively working to address the email delivery delays. We appreciate your patience as we continue to work towards a solution. Next update will be in an hour. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 17:27 UTC
[Identified] We continue to address email delivery delays. While there is no new information to share at this time, we are actively working on a resolution. Another update will be provided in one hour. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 16:19 UTC
[Identified] We have identified an issue causing delays in email delivery and are actively working to resolve the issue. We anticipate providing an update within the next hour. Details in: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 15:31 UTC
[Investigating] No material updates to report. We are still working with the vendor to identify the cause. Next update will be posted when we know more. For more information: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 15:05 UTC
[Investigating] We are working with the email vendor to identify the cause. For more information: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 14:40 UTC
[Investigating] We are still actively investing reports of delayed emails. More information: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404

January 16, 2024 14:10 UTC
[Investigating] We have identified a problem where emails are being delayed intermittently. More information: gitlab.com/gitlab-com/gl-infra/production/-/issues/17404.

Back to current status