Website, API, Git Operations
October 30, 2023 18:33 UTC
October 30, 2023 17:58 UTC
October 30, 2023 17:28 UTC
[Identified] Performance continues to improve and the team is continuing to work on mitigations to prevent future impact.
October 30, 2023 17:09 UTC
[Identified] We continue to work towards full mitigation. Performance of GitLab.com is returning, though project import remains partially disabled while the team investigates. October 30, 2023 16:54 UTC
[Identified] A likely cause of the database load has been identified. Our incident response team has temporarily disabled part of the project import feature while we continue to investigate.
October 30, 2023 16:32 UTC
[Investigating] We are seeing signs of improvement, and the team has narrowed the potential causes. Mitigation and additional investigation are in progress.
October 30, 2023 16:23 UTC
[Investigating] We've confirmed potential impacts to Git operations and API as well. Investigation still ongoing.
October 30, 2023 16:10 UTC
[Investigating] The incident response team is continuing to investigate causes of the increased database usage, additional teams are being brought in to assist.
October 30, 2023 15:55 UTC
[Investigating] We are investigating increased database usage as a primary cause. We will update as more information becomes available.
October 30, 2023 15:39 UTC
[Investigating] We are currently investigating availability issues with on GitLab.com. We will update as more information becomes available.