A subset GitLab.com Pages sites not loading properly Operational

Components

GitLab Pages

Locations

Google Compute Engine



July 15, 2022 00:13 UTC
[Resolved] Fix has been applied to Production and the issue has been resolved. A full timeline of this incident and more details available at gitlab.com/gitlab-com/gl-infra/production/-/issues/7438.

July 14, 2022 23:46 UTC
[Monitoring] Fix has been deployed to Production. We continue to monitor impact on GitLab Pages. See gitlab.com/gitlab-com/gl-infra/production/-/issues/7438 for more details.

July 14, 2022 22:45 UTC
[Monitoring] Our mitigation measures are back in place, GitLab Pages sites should be loading correctly once again. We continue to monitor until the fix to the underlying issue is deployed into production. See gitlab.com/gitlab-com/gl-infra/production/-/issues/7438 for more details.

July 14, 2022 22:26 UTC
[Identified] As part of testing the fix to this issue, the previous mitigation measure was removed and the problem is present again. We work on mitigating it back ASAP. ETA for definitive fix in production is ~1 hour. See gitlab.com/gitlab-com/gl-infra/production/-/issues/7438.

July 14, 2022 18:38 UTC
[Monitoring] This incident is currently mitigated. The underlying problem will be fixed by an MR pending to be deployed into production within the next hours. Next update in 5 hours or sooner. See gitlab.com/gitlab-com/gl-infra/production/-/issues for further details.

July 14, 2022 17:19 UTC
[Monitoring] GitLab Pages version has been rolled back on GitLab.com and we are noticing improvements on the served sites, we continue to monitor to ensure the issue is mitigated for all use-cases. See gitlab.com/gitlab-com/gl-infra/production/-/issues/7438 for more details.

July 14, 2022 17:01 UTC
[Investigating] The investigation is still ongoing. We have an MR in flight to roll GitLab Pages back to a version we believe may mitigate the issue. Please stay tuned on gitlab.com/gitlab-com/gl-infra/production/-/issues/7438.

July 14, 2022 16:41 UTC
[Investigating] Investigation is still ongoing. We have identified a potential cause and are currently considering reverting the suspect changes. See more details on gitlab.com/gitlab-com/gl-infra/production/-/issues/7438.

July 14, 2022 16:17 UTC
[Investigating] We continue to investigate the cause of the Gitlab Pages sites errors analyzing recent merge requests and also investigating with GCP. See gitlab.com/gitlab-com/gl-infra/production/-/issues/7438 for further details.

July 14, 2022 15:58 UTC
[Investigating] Initial status update emphasized docs.gitlab.com as the affected site, this update is to clarify that there are more Pages-hosted sites affected by this, continue to track the incident at gitlab.com/gitlab-com/gl-infra/production/-/issues/7438

July 14, 2022 15:52 UTC
[Investigating] We continue to investigate the rendering errors affecting sites hosted on GitLab Pages. For more information see gitlab.com/gitlab-com/gl-infra/production/-/issues/7438 for incident tracking.

July 14, 2022 15:25 UTC
[Investigating] docs.gitlab.com (and possibly other pages sites) are showing partial or non-renderable pages, see gitlab.com/gitlab-com/gl-infra/production/-/issues/7438 for further details.

Back to current status