Epic Issue Relationships Deleted Operational

Components

Website, Background Processing

Locations

Google Compute Engine



December 15, 2021 15:30 UTC
[Resolved] We’ve believe we have now successfully restored all deleted epic and issue relations that were affected by this bug. For more details, see the incident issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 09:25 UTC
[Identified] We’ve successfully restored the majority of deleted epic and issue relations that were affected by this bug and are working on restoring the rest. If you’re still affected by the incident, please let us know in the incident issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 09:09 UTC
[Identified] We’ve successfully restored the majority of deleted epic and issue relations that were affected by this bug and are working on restoring the rest. If you’re still affected by the incident, please let us know in the incident issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 06:49 UTC
[Identified] We’ve increased the Severity of this incident to Severity 2, engaged additional engineers, and increased the urgency for resolution. Our team is actively working on the fix. gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 05:48 UTC
[Identified] We're still working on and reviewing the fix to make sure it's production ready before deployment. gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 04:42 UTC
[Identified] We're working on a fix and we will deploy it to GitLab.com after reviewing. At the moment, We will update you hourly from now on until we resolve the incident. See latest update at gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 04:06 UTC
[Identified] No material updates to report. We’re continuing to work on restoring the missing epic-issue links. gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 03:32 UTC
[Identified] No material updates to report. We’re continuing to work on restoring the missing epic-issue links. gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 02:57 UTC
[Identified] No material updates to report. We’re still working on restoring the missing epic-issue links. gitlab.com/gitlab-com/gl-infra/production/-/issues/6072#note_775901346

December 15, 2021 02:08 UTC
[Identified] We have identified the bug that caused the deletion of the issue relationships. We are moving forward with a restore and will post an update soon. gitlab.com/gitlab-com/gl-infra/production/-/issues/6072

December 15, 2021 01:46 UTC
[Investigating] We have been made aware of epic issue relationships being deleted . We are currently investigating this internally at gitlab.com/gitlab-com/gl-infra/production/-/issues/6072 and more updates will be provided soon.

Back to current status