Database latency resulting in 500 errorsOperational

Components

Website, API, Git Operations, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, CI/CD - Hosted runners on Windows, Background Processing, GitLab Customers Portal, Support Services, packages.gitlab.com, version.gitlab.com, forum.gitlab.com, Canary

Locations

Google Compute Engine, Azure, Digital Ocean, Zendesk, AWS



March 15, 2021 14:19 UTC
[Resolved] While the root cause is still being investigated, we have seen no further alerts and GitLab.com is fully operational. We are therefore marking this incident as resolved. For further details please check: gitlab.com/gitlab-com/gl-infra/production/-/issues/3962

March 15, 2021 12:51 UTC
[Monitoring] Gitlab.com appears to be stable, with no additional updates to share. Our engineers are still monitoring our application and investigating the root cause of this problem. Details in issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/3962

March 15, 2021 12:35 UTC
[Investigating] No material updates, our engineers are investigating the root cause. We're currently waiting for more database replicas to come online to help with the load. Details in issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/3962

March 15, 2021 12:15 UTC
[Investigating] We're still experiencing 500 errors on GitLab.com, investigation is underway. Details in issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/3962

March 15, 2021 11:51 UTC
[Investigating] We're still investigating the overall cause of the issue and are currently checking if this could be related to database re-indexing of a particular table. Details in issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/3962

March 15, 2021 11:29 UTC
[Investigating] We are experiencing database latency resulting in customers seeing 500 errors when trying to reach GitLab.com. We are currently investigating. Details in issue: gitlab.com/gitlab-com/gl-infra/production/-/issues/3962

Back to current status