GitLab.com is experiencing degraded availability because of high database load.Operational

Components

Website, API, Git Operations, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, CI/CD - Hosted runners on Windows, Background Processing, GitLab Customers Portal, Support Services, packages.gitlab.com, version.gitlab.com, forum.gitlab.com, Canary

Locations

Google Compute Engine, Azure, Digital Ocean, Zendesk, AWS



October 24, 2020 11:32 UTC
[Resolved] GitLab.com is back to operating normally.

October 24, 2020 11:19 UTC
[Monitoring] GitLab.com is back to operating normally. We are continuing to monitor on the incident issue.

October 24, 2020 10:57 UTC
[Identified] We are continuing to investigate the origin of some slow database queries. We are tracking on gitlab.com/gitlab-com/gl-infra/production/-/issues/2885.

October 24, 2020 10:27 UTC
[Identified] We have identified a particular endpoint that was related to the issues and have disabled it temporarily on GitLab.com. The application appears to be recovering, but we are continuing to investigate.

October 24, 2020 10:02 UTC
[Investigating] We are continuing to investigate issues related to high load on the DB cluster for GitLab.com.

October 24, 2020 09:36 UTC
[Investigating] GitLab.com is experiencing degraded availability because of high database load. We are investigating.

Back to current status