August 24, 2020 16:08 UTC
[Resolved] Uploads limits for artifacts have been restored and previously succeeding uploads should be succeeding again! We apologize for any inconvenience this change caused.
August 24, 2020 15:45 UTC
[Monitoring] We've identified the other areas where our setting needed to be updated and are working quickly to confirm the change has the full, and originally desired, impact.
August 24, 2020 15:25 UTC
[Identified] We're still trying to identify the underlying stickiness that's causing the upload limit to remain at 50 MB. Our suspicion remains that an application cache is retaining the old value.
August 24, 2020 15:12 UTC
[Identified] We suspect the application setting for the Maven artifacts upload limit is cached in the application. We're working to confirm this, so that we can put the new threshold into effect immediately. Artifacts larger than 50 MB remain blocked.
August 24, 2020 15:01 UTC
[Monitoring] We've moved the default upload max size upward to a very roomy amount. We're monitoring users' pipelines to determine whether or not uploads for affected customers are succeeding again.
August 24, 2020 14:43 UTC
[Identified] A recent release to GitLab introduced a max upload size for Maven artifacts. If users' build pipelines, or other workflows, attempt to upload beyond 50MB they will fail. We're working to increase the upper bound shortly to unblock affected users.