Cloudflare DNS issuesOperational

Components

Website, API, Git Operations, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, CI/CD - Hosted runners on Windows, Background Processing, GitLab Customers Portal, Support Services, packages.gitlab.com, version.gitlab.com, forum.gitlab.com, Canary

Locations

Google Compute Engine, Azure, Digital Ocean, Zendesk, AWS



July 17, 2020 22:34 UTC
[Resolved] Thanks everyone for their patience. We have seen traffic resume normally. Any review will continue through the incident issue gitlab.com/gitlab-com/gl-infra/production/-/issues/2433

July 17, 2020 22:00 UTC
[Monitoring] Some users are still experiencing issues accessing GitLab services especially if they're using 1.1.1.1 Cloudflare's DNS. Cloudflare's status page also suggests some locations are still affected. We recommend using a different DNS resolver at least temporarily. More details gitlab.com/gitlab-com/gl-infra/production/-/issues/2433#note_381587434

July 17, 2020 21:39 UTC
[Monitoring] Cloudflare seems to have resolved their DNS issues, and all services are operational now. We are monitoring for now. An incident issue was created and reviewed in gitlab.com/gitlab-com/gl-infra/production/-/issues/2433

July 17, 2020 21:33 UTC
[Identified] We have confirmed that the Cloudflare issue has affected all our services including Support's ZenDesk instances and our status page. We will continue to provide updates as we learn more.

July 17, 2020 21:22 UTC
[Investigating] GitLab.com is experiencing issues related to DNS with Cloudflare. We are investigating.

Back to current status