High volume credential stuffing and password spraying eventOperational

Components

Website, API, Git Operations, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, CI/CD - Hosted runners on Windows, Background Processing, GitLab Customers Portal, Support Services, packages.gitlab.com, version.gitlab.com, forum.gitlab.com

Locations

Google Compute Engine, Azure, Digital Ocean, Zendesk, AWS



April 28, 2020 20:37 UTC
[Resolved] After a period of monitoring the implementation of the mitigation we put in place, the attack has subsided and the issue appears resolved.

April 28, 2020 19:23 UTC
[Identified] We're beginning to implement some countermeasures to mitigate the attack and are continuously monitoring the impact on GitLab.com. Stand by for further updates.

April 28, 2020 18:54 UTC
[Investigating] GitLab.com is seeing high volume credential stuffing and password spraying attempts. We're working to limit the impact but the volume of unique and regularly rotating IP's is making it tough. Stay tuned.

Back to current status