Website, API, Git Operations, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, CI/CD - Hosted runners on Windows, Background Processing, GitLab Customers Portal, Support Services, packages.gitlab.com, version.gitlab.com, forum.gitlab.com
Google Compute Engine, Azure, Digital Ocean, Zendesk, AWS
April 8, 2020 15:12 UTC
[Monitoring] Although Google Cloud Platform (GCP) hasn't announced the "all clear", we have observed most of our systems recovering. We're also hearing from our account manager that other GCP customers are observing similar recoveries. We'll continue to monitor, and we'll only resolve the incident once we have firm confirmation from GCP that they've recovered.
April 8, 2020 14:57 UTC
[Monitoring] Although we were primarily impacted by Google Cloud Storage failures, we've confirmed that all API requests to Google Cloud Platform from our systems have been failing since the start of this incident. We've received confirmation from our TAM and will be monitoring status.cloud.google.com and open issues for recovery confirmation. April 8, 2020 14:45 UTC
[Identified] We're confident that the issue is related to Google Cloud Storage. We're working with our TAM to confirm the issue and are searching for any other means available to us to ensure performance doesn't decrease further.
April 8, 2020 14:30 UTC
[Investigating] This status update is providing status adjustments for each individual component in our stack.
April 8, 2020 14:27 UTC
[Investigating] We're observing multiple systems with object backend storage return errors indicating the service is unavailable, which is contributing to GitLab.com increased error rates. We're continuing to investigate the underlying cause.