Website, API, Git Operations, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, Background Processing, GitLab Customers Portal, Support Services, packages.gitlab.com, version.gitlab.com
Google Compute Engine, Azure, Zendesk, AWS
August 14, 2019 16:44 UTC
August 14, 2019 16:29 UTC
[Monitoring] We're nearly back to normal. Job queues are at their expected depths, but we've not quite reached optimal processing speeds. We'll continue to monitor and expect to resolve the incident shortly.
August 14, 2019 16:05 UTC
[Monitoring] CI/CD job queues continue to fall. We're keeping a watchful eye on the database and jobs as levels trend back toward normal. At the current rate, we'll be operating at normal levels in ~15 minutes.
August 13, 2019 15:29 UTC
[Resolved] All systems are operating normally again. We identified a runaway CI pipeline that generated contention for writes on commonly accessed database table. The jobs in the pipeline have completed and we're investigating ways to safeguard similar actions from having this type impact on the platform. We apologies for any inconvenience you may have incurred!
August 13, 2019 15:01 UTC
[Monitoring] Web request latency on GitLab.com is back at operation levels. We'll continue to monitor. Thanks for your patience! August 13, 2019 14:48 UTC
August 13, 2019 14:22 UTC
[Investigating] We are continuing to investigate degraded performance on web requests to GitLab.com. August 13, 2019 13:58 UTC