Elevated Error Rates on GitLab.comOperational

Components

Website, API, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, Background Processing

Locations

Google Compute Engine, Digital Ocean



June 3, 2019 00:04 UTC
[Resolved] We are no longer seeing errors and Google Cloud has resolved the issue as of 23:00 UTC. Any further information can be found on the issue at gitlab.com/gitlab-com/gl-infra/production/issues/862

June 2, 2019 20:17 UTC
[Monitoring] We are continuing to monitor issues with GitLab.com . They appear to be related to Google Cloud issues. We will continue to update on gitlab.com/gitlab-com/gl-infra/production/issues/862

June 2, 2019 19:41 UTC
[Monitoring] We are continuing to monitor issues with GitLab.com. We are tracking on gitlab.com/gitlab-com/gl-infra/production/issues/862.

June 2, 2019 19:29 UTC
[Monitoring] GitLab.com is now available. There was a failover on our DB and services are now working normally. We'll continue to monitor.

June 2, 2019 19:21 UTC
[Identified] We are currently investigating a database failover on GitLab.com that's led to elevated errors rates and latencies. More details in working doc at docs.google.com/document/d/1RM3QnuJ4FPH10J3UrJS0T26d-mn_Dd11-jmZweHQVV8/edit

June 2, 2019 19:04 UTC
[Investigating] We are investigating elevated error rates on GitLab.com.

Back to current status