Investigating High Error Rate on GitLab.com requestsOperational

Components

Website, API, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, Background Processing

Locations

Google Compute Engine, Digital Ocean



January 7, 2019 15:22 UTC
[Resolved] All GItLab.com systems are running normally.

January 7, 2019 15:07 UTC
[Monitoring] All GitLab.com services are operating normally. We will put further updates and a link to the RCA on gitlab.com/gitlab-com/gl-infra/production/issues/640. We apologize for the inconvenience!

January 7, 2019 14:55 UTC
[Monitoring] GitLab.com and GitLab Pages are both operational. We are continuing to monitor the health of the stack.

January 7, 2019 14:44 UTC
[Monitoring] While we bring back services on GitLab.com , the GitLab pages will have degraded performance for a short period of time.

January 7, 2019 14:42 UTC
[Monitoring] We have repaired the database backends for GItLab.com and are continuing to monitor the health of the system.

January 7, 2019 14:33 UTC
[Identified] We have identified an issue with our database VMs and are working on restoring service.

Back to current status