Git HTTP Authentication ProblemsOperational

Components

Website, API, Container Registry, GitLab Pages, CI/CD - Hosted runners on Linux, Background Processing

Locations

Google Compute Engine, Digital Ocean



October 26, 2018 17:14 UTC
[Resolved] Resolving incident after monitoring.

October 26, 2018 15:56 UTC
[Monitoring] The fix for the https authentication issues has been deployed and we are monitoring. Git over https should again be working.

October 26, 2018 15:48 UTC
[Identified] We are starting to roll out the patch for the git https issues to our fleet.

October 26, 2018 15:23 UTC
[Identified] We have applied a patch to our canary for the git over https issues and are verifying. The rest of the production fleet soon.

October 26, 2018 15:01 UTC
[Identified] We are testing a fix which should resolve the https authentication issues with git operations.

October 26, 2018 12:32 UTC
[Identified] We have identified an issue which is causing all Git HTTPS authentication for users using private access tokens - including all 2FA users - to fail. Apologies for any inconvenience. We are urgently working on a fix. Please switch to Git SSH or password authentication while we work on a resolution. Further details available at gitlab.com/gitlab-com/gl-infra/production/issues/536

Back to current status